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Introduction to SBL Development System
SBL Development System for Windows is a graphical block language
editor with many powerful integrated debugging tools to help you create,
debug and maintain SAF Block Language programs quickly and efficiently.

Features
Graphical block language editor
Password protected macros
Graphical annunciator
16 channel real-time scope
16 channel chart recorder with trigger
Text based multi node annunciator
All objects snap to a grid for easy alignment
Multiple zoom levels
Symbol table for quickly locating symbol names
Context sensitive speed bar
Context sensitive popup menus
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Main Window

Main window title bar
If a project is open the project name will be appended to the main title.
Main menu
Hi Light a menu command and press
command.

for a description of that

Speed bar
The speed bar contains icons which function as buttons to provide quick
access to some of the more frequently used menu commands. The
commands available from the speed bar depend on the type of window
currently active.

Main window client area
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All SBL windows are confined to the main window client area. Windows
can be tiled or cascaded within this space and the project and report
windows are tiled and cascaded in the bottom portion of this space.
Status bar
The status bar displays various messages including fly by hints for speed
bar buttons, as well as cursor coordinates for sheet windows and the
modified status of the current window.
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Introduction to SBL Programming
The SBL Development System has been developed by SAF Drives and
Automation to provide an efficient, user friendly programming environment
for creating, debugging and maintaining SAF Block Language programs.
SBL programs are created by combining graphical objects such as blocks,
constants, labels and tags. These objects are placed on sheets and
connected together using graphical connections. Connections between
sheets are made by placing a label on a connection in one sheet which can
then be referenced from labels on any other sheet in the project. Labels can
also be used to make connections between points on the same sheet. A
symbol table with browse and search features is provided to make using
labels easier and more efficient. Blocks are chosen from SBL block libraries
which can be updated as new functions are added to the SAFphire.
Constants provide a means of initializing values within an SBL program such
as limits, references, scaling factors, etc. When connected to tags these
constants can also be adjusted or tuned thro ugh the hand held terminal of the
SAFphire. Hand terminal access passwords are defined by placing a
password table within the program. Fault messages can also be defined by
adding a fault table to the program. Comments can be placed throughout
SBL drawings as a means of documenting changes or explaining the
operation of the program. Revision blocks are also available to track
modifications made to each sheet.
Macros provide a means for the user to create custom blocks. Macros are
created by placing objects on a sheet to perform a desired function. Two
additional objects, inputs and outputs, are available when creating macros.
Connections to objects within a macro from objects on other sheets or
macros can only be made through inputs and outputs. Labels can still be
used to make connections within a macro. When editing a macro, browsing
the symbol table will only display symbols valid for that macro. When a macro
is added to a sheet or other macro it will have the appearance of a block.
The input and output names of this block will match the names of the input
and output objects that were placed on the macro sheet. The only limit to the
size of a macro is that it must fit on a single sheet, but macros can also
include other macros. The SBL editor and compiler support nested macros
up to 16 levels deep. Macros can be added as many times as needed and to
as many sheets as needed. The only limit is that a macro can not be used
more than 999 times in the same program which is more than adequate for
even the largest programs. Macros, when used effectively, can save time,
improve readability and reduce the size of your projects making them easier
to maintain. Any changes made to a macro are automatically made to every
occurrence of that macro in the project. Because macros can be used more
than once in a project it is advised that hand terminal tags are not used in

Page 10

SBL Users Guide

macros since this would result in the existence of more than one tag with the
same name. This will generate warnings when the project is compiled and
only the last occurrence of the macro will have a valid tag.
Another feature of macros is the ability to password protect sections of your
program. Macros that have been saved with a password cannot be viewed,
edited or printed without first entering the passwo rd. Whenever the SBL
editor attempts to open or save a macro it prompts the user for the
password. When saving the macro the user also has the option of changing
the password.
Although an SBL program can consist of only a single sheet most require
many sheets to implement all of the required functionality. Projects are used
to combine many sheets into one SBL program. Sheets are added to a
project to inform the SBL editor and compiler which sheets are to be
included in the program. The execution order of the sheets is determined by
the order in which they appear in the project listing. This order can be
changed by dragging and dropping the file names in the project window. The
project window will also display any macros that are included in any sheet or
macro. All File types that can be created with SBL can be added to a project
so that copying or printing a project will include all files related to the project.
File type other than sheets or macros are ignored by the compiler so they
can appear anywhere in the project listing.

Page 11

SBL Users Guide

Logging In As Administration
Before anyone can access the SBL Development System they must be
assigned a user name and password. The user name of the user currently
logged in is placed in the title blocks of all sheets created or edited by that
user. It is also included in the information table downloaded to the SAFphire
whenever a program is downloaded.
Only the system administrator using the user name super is allowed to add,
edit or remove user passwords. When first installed the system administrator
password is user but should be changed to prevent unauthorized access.
See Changing System Administrator Password for information on how to do
this.
To add, edit or remove passwords enter super for the user name and the
system administrator password and click on the Admin button or press
to access the Log In Administration dialog box. A list of the
current user names and their passwords will be displayed.

Note: Both the user name and password are case sensitive.

Adding New Users:
To add a new user click the Add button or press
to access the
Add User dialog box. Enter the new user name and password and click the
OK button or press the
key to save them to the user list. Clicking the
Cancel button or pressing the
key will abort without saving the new
user name and password. The new user name and password will be now be
added to the list. Repeat this process for all new users to be added and click
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the OK button when finished.

Editing User Names and Passwords:
To edit an existing users user name or password select the user from the list
by clicking the left mouse button while the cursor is over the user name or
password to be edited. Then click the Edit button or press
to
access the Edit User dialog box. Both the user name and password can be
edited as required then click the OK button or press the
the changes. Clicking the Cancel button or pressing the
abort without saving any changes.

key to save
key will

Removing Users:
To remove an existing user select the user from the list by clicking the left
mouse button while the cursor is over the user name or password to be
removed. Then click the Remove button or press
to remove the
user name and password from the list.
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Changing System Administrator Password
To change the system administrator password follow the procedure for
adding a new user and enter super for the user name. The password
entered will be the new system administrator password and user will no
longer be accepted. To return to using user as the password simply remove
the super user from the list.
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Logging In as User
In order to access the SBL Development System users must first log in
using the user name and password that has been assigned to them by the
system administrator. The user name is placed in the title block of any sheet
modified and saved by this user. The user name is also stored in the
SAFphire if the user downloads a new block program and will appear in the
node status information returned by the SAFphire.

Note: Both the user name and password are case sensitive.
User Name
Enter the user name assigned to you by the system administrator.
Password
Enter the password assigned to you by the system administrator.
Login button
Click this button to log in and enter the SBL Development System.
Exit button
Click this button or press
and return to Windows.

to exit the SBL Development System

Admin button
Click this button to log in as the system administrator.
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Menu Commands
File Menu
Comm
and

Speed
Bar

Description

New

Create new file.

Open

Open an existing file.

Save

Save the contents of the active window.
Sheets and macros are saved only if they
have been modified. This is to prevent
changing the date stamp of the file since the
date stamp is used to determine if a compile
is required. When saving a Macro the user will
be prompted for the macro's password even if
the macro was not previously assigned a
password so that the user can assign or
change the password.

Save As

Save the contents of the active window to a
new file.

Save All

Save the contents of all open windows.

Close

Close the active window. If the contents of the
active window have been modified the user will
be prompted to save the changes. Closing the
project window does no t close the project.

Import
Group

Import a group of objects. This function is
provided to allow the user to import groups
exported with a previous version of SBL. This
function may be removed from future versions
of SBL.

Print

Add the contents of the active window to the
print queue.

Printer
Setup

Select and setup the printer to be used by
SBL. Changing the orientation will not have
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any effect on how files are printed. Sheet files
are always printed in the same orientation as
they were created. All other file types default to
portrait orientation.
Exit

Exit SBL Development System prompting the
user to save any files that have been modified.
Save the current states of all open windows to
the desktop file.

Project Menu
Comm
and

Description

New

Create a new project.

Open

Open an existing project.

Close

Close the current project prompting the user to
save any files that have been modified. Save
the current states of all open windows to the
desktop file.

Add File

Add an existing file to the current project.

Copy

Backup the current project to a new directory
and/or drive.

Print All

Print all files that have been added to the
current project as well as the contents of the
project file, the last compiler report and the
symbol table for the current project.

Make

Compile only those sheets in the current
project that have changed since last compile.

Build All

Compile all sheets in current project.

Edit Menu
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Comm
and

Speed
Bar

Description

Cut

Remove the selected object(s) from the sheet
or macro window and place them in the
clipboard.

Copy

Copy the selected object(s) from the active
sheet or macro window to the clipboard.

Paste

Copy the clipboard contents to active sheet or
macro window.

Search Menu
Comm
and

Speed
Bar

Description

Find

Find object by name on active sheet.

Find &
Rename
Find Next

Find and rename object on active sheet.
Find the next matching object in the active
window.

Add Menu
Comm
and

Speed
Bar

Description

Block

Add a block from the SBL block library to the
active sheet or macro window.

Macro

Add a macro to the active sheet or macro
window.

Constant

Add a constant to the active sheet or macro
window.
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Connection

Add a connection to the active sheet or macro
window.

Comment

Add a comment to the active sheet or macro
window.

Label

Add a label to the active sheet or macro
window.

Tag

Add a hand terminal tag to the active sheet or
macro window.

Revision
Block

Add a revision block to the active sheet or
macro window

Fault Table

Add a fault table to the active sheet or macro
window.

Password
Table

Add a password table to the active sheet or
macro window.

Input

Add an input to the active macro window.

Output

Add an output to the active macro window.

Parameters

Add parameters to the active annunciator
window.

View Menu
Comm
and
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Speed
Bar

Description

Project

Display the project window.

Compiler
Report
Symbols

Display the compiler report window.

Print Queue

Display the print spooler queue.

Zoom In

Zoom in one level to show more detail.

Display the browse symbol table dialog box.
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Zoom Out

Zoom out one level to show less detail.

Zoom Min

Zoom out to the minimum zoom level showing
as little detail as possible.

Zoom Max

Zoom in to the maximum zoom level showing
as much detail as possible.

Zoom
Window

Allows the user to select an area to zoom in
on. Select an area to zoom in on by positioning
the zoom window cursor at one corner of a
rectangular area. Click and hold the left mouse
button and drag the zoom window outline to
include the area to be displayed. SBL will
zoom to the highest zoom level that will display
the entire area outlined by the zoom window.
The sheet will scroll when the cursor reaches
the edge of the window allowing an area not
currently visible to be selected. Press the
key to cancel this mode without
zooming. If the left mouse button is pressed
and released without selecting an area SBL
will zoom to the maximum zoom level and
position the cursor position in the center of the
window if possible.

Zoom Point

Selecting Zoom Point will cause the mouse
cursor to change to a magnifying glass.
Positioning this cursor over a point on a s heet
and clicking the left mouse button will cause
SBL to zoom to the first zoom level where text
is displayed and center this point in the
window if possible. If the current zoom level is
already at or above this level zoom point has
no effect..

Tools M enu
Comm
and
Annunciate

Speed
Bar

Description

Toggle the annunciator on or off.
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Download

Download current program to the selected
SAFphire node.

Upload
Data

Upload the data table from the selected
SAFphire node and update all constants in the
program.

Remote
Save

Save the values in the data table to non-volatile
memory on the selected SAFphire node.
Constants that have been tuned since the
program was downloaded will revert back to
they're original values on power up unless a
remote parameter save command is executed.
See Communication Options for information
on configuring nodes.

Node
Status

Read and display the current status of selected
SAFphire node.

Scope

Open a real-time scope window.

Chart
Recorder
Cursors

Open a new chart recorder window.

Reset
Communic
ations
Upload
Tables

Install or reset communication module.

Restore
Tables

Download previously uploaded program tables
to the selected SAFphire node. See the
Upload Tables command for more
information.

Enable Scope and Chart Recorder cursors.
When the mouse cursor is moved over a
scope or chart recorder window a cross hair
cursor will appear when cursors are enabled.
This allows more accurate measurements of
time and values.

Upload the existing program tables from the
selected SAFphire node. These tables can
later be restored to the SAFphire using the
Restore Tables command. This is useful for
creating a backup of an existing program for
which the original files are no longer available.

SBL Users Guide

Download
Firmware
Upload
Project

Download embedded firmware to SAFphire.
Upload a compressed project archive which
was previously downloaded to a SAFphire.
This menu item is only visible when the Data
Compression Library DLL is present in the
SBL directory.

Options Menu
Comm
and

Speed
Bar

Description

Editor

Display editor options dialog box.

Compiler

Display compiler options dialog box.

Communic
ations

Display communications options dialog box.

Window Menu
Comm
and

Speed
Bar

Description

Cascade

Cascade all currently open windows. If the
Project or Compiler Report windows are
open they are arranged at the bottom of the
main window.

Tile
Vertically

Tile all currently open windows from left to right.
Windows are resized so that each window is
completely visible and as tall as possible
unless more than three windows are open. If
more than three windows are open Tile
Vertically and Tile Horizontally have the
same effect. If the Project or Compiler
Report windows are open they are arranged
at the bottom of the main window.

Tile
Horizontally

Tile all currently open windows from top to
bottom. Windows are resized so that each
Page 23
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window is completely visible and as wide as
possible unless more than three windows are
open. If more than three windows are open
Tile Vertically and Tile Horizontally have the
same effect. If the Project or Compiler
Report windows are open they are arranged
at the bottom of the main window.
Arrange
Icons

Arrange the icons of all minimized windows at
the bottom of the main window.

Close All

Opens a sub menu from which the user can
choose the type of windows to close. If the
contents of a window to be closed have been
modified SBL will prompt the user to save the
changes. If a project is open closing all
windows will not close the project. The
following is a list of the available window types
that may be closed using this command.
Windows - closes all windows
Sheet Windows - closes all sheet windows
Macro Windows - closes all macro windows
Annunciator Windows - closes all
annunciator windows
Recorder Windows - closes all chart
recorder windows
Text Windows - closes all text windows

Help Menu
Comm
and
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Speed
Bar

Description

Contents

Open SBL help and display contents.

Search for
help on...
Using Help

Open SBL help and display search dialog box.

Block
Library

Open help for currently loaded SBL block
library and display contents.

Open Windows help on help.

SBL Users Guide

Block

Display help for selected block.

About SBL

Display SBL About dialog box.
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Creating New Files
Select New from the File menu, or click on the new file button
speed bar, to display the New File dialog box.

on the

File Name:
Enter the name of the new file to create. A new subdirectory can also be
created by preceding the file name with the new directory name. For
example: To create a new sheet called "control" in a new subdirectory of
the demo directory called "newdemo" enter "newdemo\control.sht". If no
extension is specified the type of file created will default to sheet. If a file
name is chosen from the list of existing files the user will be prompted to
confirm that the new file will overwrite the existing file.
List Files of Type:
Use this drop down list box to display the list of available file types.
Selecting a file type from this list will display a list of all existing files of the
selected type in the selected directory.
Below is a list of available file types that can be created from this dialog
box:
Sheet files (.sht)
Macro files (.mac)
Annunciator files(.ann)
Text files
(.txt)

Directories:
Page 26

SBL Users Guide

If a project is open the project directory will be selected otherwise the
selected directory will be the directory that contains the SBL.EXE file. The
user can select a different directory or create a new one in which to create
the file. If the file is created in a different directory and later added to the
project it will be automatically copied to the project directory.
Drives:
Use this drop down list box to select a different drive on which to create
the new file.
When creating a new sheet or macro file the Sheet Options dialog box will be
displayed allowing the user to select the sheet size and orientation as well as
the font size used to print the sheet. Title blo cks are automatically added to
sheet or macro files. Title blocks may be moved but cannot be copied or
deleted. Most of the fields of the title block are filled in by SBL, the user can
edit the title block description by double clicking the left mouse button on the
title block or by positioning the cursor over the title block and pressing the
key. See Editing Title Block for more information.
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Sheet Options
The sheet options dialog box allows the user to specify the sheet size and
orientation as well as the font size when creating a new sheet or macro.

Page Size:
Select the paper size you wish to use when printing this sheet. The 3HP
indicates three hole punched and leaves an extra wide margin along one
side.
Font Size:
Select the font size to use when printing this sheet. The font size is used to
determine the size of the objects on the sheet, the larger the font size the
fewer objects that will fit on the sheet.
Orientation:
Select the orientation of the sheet. Selecting portrait orientation will
display and print the sheet with the longest side vertical. Selecting
landscape will display and print the sheet with the longest side horizontal.
Due to rounding errors when scaling to match the screen resolution sheets
may sometimes appear square but will print correctly.
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Title Block
Title blocks are automatically placed on each sheet or macro created. The
default position for the title block is the bottom right corner of the sheet but
can be moved to any location on the sheet. Title blocks cannot be copied or
deleted. Most of the title block's fields are automatically filled in by SBL. The
description field is the only field that can be edited by the user. To edit the
description double click the left mouse button on the title block or press the
key while the cursor is over the title block to display the Title Block
dialog box. The title bar of the dialog box will identify the sheet on which the
title block is located.
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Opening a File
Select Open from the File menu, or click on the open file button
speed bar, to display the Open File dialog box.

on the

File Name:
Enter the name of the file to open or select it from the list of available files.
If no extension is specified the type of file to open will default to sheet.
List Files of Type:
Use this drop down list box to display the list of available file types.
Selecting a file type from this list will display a list of all existing files of the
selected type in the selected directory.
Below is a list of available file types that can be opened from this dialog
box:
Sheet files (.sht)
Macro files (.mac)
Annunciator files(.ann)
Text files
(.txt)
Project files (.prj)
Scope files (.rsc)
Recorder files
(.rec)
Directories:
If a project is open the project directory will be selected otherwise the
selected directory will be the directory that contains the SBL.EXE file.
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Drives:
Use this drop down list box to select a different drive from which to open a
file.
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Renaming Files
Select Save As from the File menu to display the Save As dialog box. The
File Name list box will display a list of all existing files of the selected type in
the selected directory. Select the directory and enter the name of the file
being saved or select a file from the list to overwrite. You can also specify a
new directory to save the file to and SBL will create the new directory.

File Name:
Enter the new name of the file to save the contents of the current window
to. A new subdirectory can also be created by preceding the file name
with the new directory name. For example: To save the current sheet to a
new sheet called "spdloop2" in a new subdirectory of the demo directory
called "newdemo" enter "newdemo\spdloop2.sht". The extension does not
need to be specified as the extension will be determined by the type of file
being saved. If a file name is selected from the list of existing files the user
will be prompted to confirm that the new file will overwrite the existing file.
List Files of Type:
Only the file type matching the type of file being saved will be available.
Directories:
If a project is open the project directory will be selected otherwise the
selected directory will be the directory that contains the SBL.EXE file. The
user can select a different directory or create a new one in which to save
the file. If the file is saved in a different directory and later added to the
project it will be automatically copied to the project directory.
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Drives:
Use this drop down list box to select a different drive on which to save the
new file.
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Creating a New Project
Select New from the Project menu, or click on the new project button
on
the speed bar, to display the New Project dialog box. It is possible to have
more than one project per directory and include the same sheets in more
than one project. It is recommended that a new directory be created for each
project so that each project has it's own copy of all sheets. If you choose to
create multiple projects in the same directory and use the same sheets in
more than one project be aware that any changes made to a sheet in one
project will affect the other projects in which that sheet was used.

File Name:
Enter the name of the new project to create. A new subdirectory can also
be created by preceding the project name with the new directory name.
For example: To create a new project called "project1" in a new
subdirectory of the demo directory called "project1" enter
"project1\project1.prj". The extension does not need to be specified as
projects are the only file type that can be created from this dialog box. If a
project name is chosen from the list of existing projects the user will be
prompted to confirm that the new project file will overwrite the existing file.
List Files of Type:
Project files are the only type of file that can be selected using this dialog
box.
Directories:
If a project is already open the current project directory will be selected
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otherwise the selected directory will be the directory that contains the
SBL.EXE file. The user can select a different directory or create a new
one in which to create the new project.
Drives:
Use this drop down list box to select a different drive on which to create
the new project.
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Opening a Project
Select Open from the Project menu, or click on the open project button
on the speed bar, to display the Open Project dialog box.

File Name:
Enter the name of the project to open or select it from the list of available
projects.
List Files of Type:
Project Files are the only file type that can be selected using this dialog
box.
Directories:
If a project is open the project directory will be selected otherwise the
selected directory will be the directory that contains the SBL.EXE file.
Drives:
Use this drop down list box to select a different drive from which to open a
project.
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Adding Files To a Project
Select Add File from the Project menu, or click on the add file button
on
the speed bar, to open the Add File To Project dialog box. When a file is
added to a project the Project Name field of the title block on that sheet is
updated with the name of the project it was added to. Also the Page ## of ##
fields in the title blocks of all sheets belonging to the project are updated.

File Name:
Enter the name of the file to add or select it from the list of available files. If
no extension is specified the type of file to add will default to sheet.
List Files of Type:
Use this drop down list box to display the list of available file types.
Selecting a file type from this list will display a list of all existing files of the
selected type in the selected directory.
Below is a list of available file types that can be added to a project:
Sheet files (.sht)
Macro files (.mac)
Annunciator files(.ann)
Text files
(.txt)
Scope files (.rsc)
Recorder files
(.rec)
Directories:
The project directory will be selected when this dialog box is opened. If a
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file is added from another directory it will automatically be copied to the
project directory.
Drives:
Use this drop down list box to select a different drive from which to add a
file.
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Copying a Project
Select Copy from the Project menu to open the Select Project To Copy
dialog box. If a new name is specified the project and all appropriate files are
renamed.
Note:
Desktop configuration files (*.dsk) contain information that may not be
compatible with other computers. Therefore it is recommended that these
files not be copied from one computer to another as errors may occur when
the project is opened on the computer that it was copied to. Using the
Project Copy command to copy projects will not copy the desktop
configuration file. And is the recommended method of backing up projects.

File Name:
Enter the name of the project to copy or select it from the list of available
projects. The extension does not need to be specified as projects are the
only file type that can be selected from this dialog box.
List Files of Type:
Project files are the only type of file that can be selected using this dialog
box.
Directories:
If a project is already open the current project directory will be selected
otherwise the selected directory will be the directory that contains the
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SBL.EXE file. The user can select a different directory from which to
select a project to copy.
Drives:
Use this drop down list box to select a different drive from which the
project is to be copied.
Note:
If the project to be copied is currently open SBL will prompt the user to
close it before continuing to copy the project. This is to ensure that all
changes are saved before copying the project. The user can choose not to
save changes before copying the project.

File Name:
Enter the name of the new project to create, SBL will default to the same
name as the project being copied.. A new subdirectory can also be
created by preceding the project name with the new directory name. For
example: To create a new project called "democopy" in a new
subdirectory of the demo directory called "democopy" enter
"democopy\democopy.prj". The extension does not need to be specified
as projects are the only file type that can be copied from this dialog box. If
a project name is chosen from the list of existing projects the user will be
prompted to confirm that the new project file will overwrite the existing
project.
List Files of Type:
Project files are the only type of file that can be selected using this dialog
box.
Page 40

SBL Users Guide

box.
Directories:
If a project is already open the current project directory will be selected
otherwise the selected directory will be the directory that contains the
SBL.EXE file. The user can select a different directory or create a new
one to copy project to.
Drives:
Use this drop down list box to select a different drive to which the project
is to be copied.
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Compiling a Program
Select Compile from the Project menu, or click on the compile project
button
or the compile sheet button
on the speed bar to compile the
current program. The progress of the compile is displayed in the compile
status box. To abort a compile click the Cancel button at any time during the
compile. When the compile is complete the compile status box will display
the total number of blocks in the program and the number of errors and
warnings generated by the compiler. When the compile status box is closed
a compiler summary will be displayed in the Compiler Report Window. The
compiler summary includes the progress of the compiler as each file was
processed as well as any warning or error messages generated by the
compiler. If the program was compiled successfully a table summary will also
be included which lists the number of blocks and constants in the program as
well as the size of each of the tables that are downloaded to the SAFphire.
See Compiler Error Messages for a detailed description of the possible
warning or error messages generated by the compiler.
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Compiler Warning And Error Messages
The compiler will continue to compile the program after encountering a condition that
generates a warning, but will abort the compile when errors are encountered. After
encountering an error the compiler will continue to compile the current sheet to try and find
all possible errors on that sheet. Warnings are generated when the comiler encounters a
condition that is suspicious and a potentional error but will not prevent the program from
being compiled. Errors are generated when the compiler encounters a condition that is
invalid.
Select a warning or error message in the compiler report window and press the
key
to display a detailed description of the warning or error. Or select a warning or error from the
lists below.
All compiler warning and error messages have the following format:
Warning or error identifier followed by a colon, the sheet name on which the warning or error
occurred, the coordinates at which the warning or error occurred followed by a brief
description of the warning or error.
Examples:
Warning 102: sheetname, [x,y] Label not attached to connection
Error 205: sheetname, [x,y] Cons tant connected to block output by label

Error 200
This error message is generated when the compiler encounters a block which is not in the
currently loaded SBL block library.

Error 201
This error message is generated when the compiler encounters a constant which is
connected to another constant on the same sheet. The cordinates of both constants are
given.

Error 202
This error message is generated when the compiler encounters two constants are
connected together by a label on the indicated sheet. The coordinates given are for the
label making this connection.

Error 203
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This error message is generated when the compiler encounters a constant which is
connected to a block output on the same sheet. The cordinates of both the constant and
the block ouput are given.

Error 204
This error message is generated when the compiler encounters a constant on one sheet
which is connected to a block output on another sheet by lables on a third sheet. The
cordinates given are that of one of the labels making the connection.

Error 205
This error message is generated when the compiler encounters a block output which is
connected to another block output on the same sheet. The cordinates of both block outputs
are given.

Error 206
This error message is generated when the compiler encounters two block outputs of blocks
on other sheets connected together by labels on the indicated sheet. The coordinates given
are for one of the labels making this connection.

Error 207
This error message is generated when the compiler encounters a block input that is not
connected to a constant or block output.

Error 208
This error message is generated when the compiler encounters a constant or a block
output connected to a block input of a different data type. The coordinates given are for the
block input. This error can also be generated when the compiler encounters a tag
connected to a constant or block output of a different data type. In this case the
coordinates given are for the tag.

Error 209
This error message is generated when the compiler encounters a tuneable tag connected to
a block output. The coordinates given are for the tag. This is invalid since block outputs can
not be tuned by the user.

Error 210
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This error message is generated when the compiler encounters a tag that has the same
name as another tag connected to a different block output or constant.

Error 211
This error message is generated when the compiler detects bad or missing entries in the
symbol table. To correct this error close the project and delete the symbol table file (*.sym)
for the project. This will cause SBL to automatically rebuild the symbol table when the
project is reopened.

Error 212
The indicated block does not contain the same number of block inputs and/or block outputs
as defined in the SBL block library.

Error 213
The indicated macro has exceeded the maximum number of nested macros allowed. SBL
supports a maximum of sixteen nested macros which is usually more than enough for most
applications. This error message usually indicates that a macro has included itself causing
an endless loop of nested macros.

Error 214
The indicated external label has no matching source label on any other sheet in the
program.

Error 215
The indicated external label is not valid since external labels are not allowed within macros.
All external connections to objects within a macro must be made using macro inputs and
outputs.

Warning 100
This warning message is generated when the compiler encounters a constant that is not
used in the program. Unused constants do not cause any problems but each constant
adds two bytes to the size of the data table that is downloaded to the SAFphire.

Warning 101
This warning message is generated when the compiler encounters a label that is not
referenced by any other labels in the program.
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Warning 102
This warning message is generated when the compiler encounters a label that is not
attached to a connection.

Warning 103
This warning message is generated when the compiler encounters a tag that is not
connected to a constant or block output.

Warning 104
This warning message is generated when the compiler encounters a tag that is not
attatched to a connection.

Warning 105
This warning message is generated when a block input is connected to an ouput of a block
that is higher in the execution order and therefore executed later in the current scan. Any
change in the data for this input will not be processed until the next scan therefore causing
a one scan delay from the time the output of the second block changes before the output of
the first block wil change.

Warning 106
This warning message is generated when the compiler encounters a tag that is connected
to the same block output or constant as another tag with the same name. The second tag
is ignored.

Warning 107
This warning message is generated when the compiler encounters a tag that is connected
to the same block output or constant as another tag.

Warning 108
This warning message is generated when the compiler encounters a fault table which
defines a fault that has already been defined in a fault table on another sheet. The
previously defined fault will be overwritten with the new fault.

Warning 109
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This warning message is generated when the compiler encounters a password table which
defines a password that has already been defined in a password table on another sheet.
The previously defined password will be overwritten with the new password.

Warning 110
The indicated tag is contained within a macro and will be ignored since tags within macros
would be duplicated each time the macro was used.

Warning 111
The indicated macro input is not connected to a constant or block output. This will result in
an error when the macro is compiled if this input connects to a block input within the
macro.

Warning 112
The indicated macro output is not connected to a constant or block output within the
macro.

Warning 113
The indicated macro output is not connected directly to a macro input with the macro.
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Find Object
Select Find Object from the Search menu, or click on the Find Object button
on the speed bar, to open the Find Object dialog box.

Search For:
Enter the string to search for.
Object Type:
Select the type of the object(s) to search for. Any combination of object
types may be selected.
Options:
Case Sensitive:
Enable this option to perform a case sensitive search.
Whole names only:
Enable this option to find only names that match exactly.
Whole words only:
Enable this option to find names that contain the specified word.
Note:
If both Whole names only and Whole words only options are selected
the Whole words only option is ignored. If neither Whole names only or
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Whole words only option is selected all names containing the specified
string will be found.
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Find And Rename Object
Select Find & Rename from the Search menu, or click on the Find &
Rename button
box.

on the speed bar, to open the Find & Rename dialog

Search For:
Enter the string to search for.
Replace With:
Enter the string to replace the existing string.
Object Type:
Select the type of the object(s) to search for. Any combination of object
types may be selected.
Options:
Case Sensitive:
Enable this option to perform a case sensitive search.
Whole names only:
Enable this option to find only names that match exactly.
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Whole words only:
Enable this option to find names that contain the specified word.
Prompt to rename:
Enable this option to confirm renaming of object to New Name.
Note:
If both Whole names only and Whole words only options are selected
the Whole words only option is ignored. If neither Whole names only or
Whole words only option is selected all names containing the specified
string will be found.
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Adding a Block
Select Block from the Add menu to open the Select Block dialog box.
Select a block from the currently loaded block library to add to the active
sheet or macro. When adding a block the user will be prompted to name the
block with a unique name. Typically this name should describe the blocks
function within the program. Position the block and click the left mouse button
or press the
key to place the block. To edit the name of an existing
block, position the cursor over the block and double click the left mouse
button or press the
key to open the Edit Object Name dialog box.

Block Library:
Displays the name of the currently loaded SBL block library.
Search for:
Enter the first few letters of the block name to quickly locate the block to be
added.
Blocks Available:
Scroll through the list of blocks available in the block library using the scroll
bar or the keyboard cursor keys to locate the block to be added. Select the
block to be added and click the OK button or double click on the selected
block.
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Note:
The execution order of blocks is determined by their graphical placement
on the sheet. The upper-left most block being the first to execute and the
lower-right most block being last. Precedence is given to left most blocks.
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Adding a Macro
Select Macro from the Add menu to open the Add Macro dialog box. Select
a macro to add to the active sheet or macro. When adding a macro the user
will be prompted to name the macro with a unique name. Typically this name
should describe the macro's function within the program. Position the macro
and click the left mouse button or press the
key to place the macro.
To edit the name of an existing macro, position the cursor over the macro
and double click the left mouse button or press the
key to open the
Edit Object Name dialog box.
Note: See Introduction to SBL Programming for more information on
macros.

File Name:
Enter the name of the macro to add or select it from the list of available
macros.
List Files of Type:
Macro Files are the only file type that can be selected using this dialog
box.
Directories:
If a project is open the project directory will be selected otherwise the
selected directory will be the directory that contains the SBL.EXE file.
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Drives:
Use this drop down list box to select a different drive from which to add the
macro.
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Macro Passwords
When opening a macro that has been password protected SBL with prompt
the user for the password. The macro password dialog box is displayed
whenever SBL attempts to open a macro for editing or printing. If the correct
password is not entered the macro file cannot be viewed or printed.

Enter Password:
The user must enter the password that exactly matches the password that
the macro was saved with before SBL will open or print the macro file.

Note: Macro passwords are case sensitive.

Changing Macro Passwords
The following dialog box is displayed every time SBL attempts to save a
macro file, prompting the user for the password of the macro and also
allowing the user to change the current password. The user is also prompted
to assign a password when the macro is first created.
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Current Password:
If the macro file was previously saved with a password the user must enter
the password that exactly matches the password that the macro file was
saved with before SBL will save any changes to the macro file. If the macro
file was not previously saved with a password this edit box will be disabled.
New Password:
Enter the new password to use when saving the macro file. Macro
passwords can be up to 15 characters in length and are not limited to
alphanumeric characters. If the macro file was previously saved with a
password the current password must be entered before any changes will
be saved to the macro file.
Confirm Password:
This password must exactly match the password entered for New
Password. This is to help prevent saving a macro file with an incorrect
password due to typing errors.
Note: Macro passwords are case sensitive.
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Adding a Constant
Select Constant from the Add menu to open the Constant dialog box. To
edit an existing constant position the cursor over the constant and double
click the left mouse button or press the
key.

Name:
Enter a name for the constant which describes this values function within
the program.
Value:
Valid Values:
Numeric: -32767 to 32768
Boolean: 0 or Off, -1 or On
(any non-zero boolean value will be automatically changed to -1)
(On and Off are not case sensitive)
Data Type:
Specify the data type of this constant. Numeric for values ranging from 32768 to 32767 or Boolean for values of On and Off only.
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Adding a Connection
Select Connection from the Add menu to add a connection to the active
sheet. Position the pencil cursor at the starting point of the connection and
click the left mouse button or press the
key to start drawing the
connection. Connections can also be started by placing the arrow cursor at
the staring point of the connection and double clicking the left mouse button.
Move the pencil cursor to the end point of the connection and click the left
mouse button or press the
key to finish drawing the connection.
Multiple segments of a connection can be drawn by moving the pencil cursor
in two directions at the same time. Click the left mouse button to end each
segment. To edit an existing connection place the arrow cursor on the
existing connection and double click the left mouse button or press the
key. Use connections to connect objects as shown below.
Connection dots are automatically placed wherever two connections connect
together.
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Adding a Comment
Select Comment from the Add menu to open the Comment dialog box.

Comment Text:
Enter the text in this multi line edit box. The comment can be as long as you
like as long as it will fit on the sheet without overlapping any other objects.
Press
to advance to the next line within the multi line edit
box.
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Adding a Label
Select Label from the Add menu to open the Label dialog box.

Sheet Name:
To make a connection to a label on another sheet enter the name of the
sheet on which the constant or label is located. The sheet name of the label
is not required to connect to a constant or label on the same sheet or if the
label being added is a source label to which other labels will connect.
Label Name:
Enter the name of the constant or label to connect to or a unique name if
the label is to be a source label to which other labels will connect.
Browse...
Click this button or press
to browse the symbol table and select
an already defined constant or label to connect to. Search strings can be
entered for Sheet Name and Label Name and only matching constants
and labels will be displayed in the Browse Symbol Table dialog box.
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Adding a Tag
Select Tag from the Add menu to open the Hand Terminal Tag dialog box.

Name:
Enter the name to be displayed when viewing this tag on the hand terminal.
Precision:
Enter the precision in terms of the number of digits to be displayed to the
right of the decimal point.
Units:
Enter a description of the value to be displayed. The units can be up to
seven characters in length and contain any displayable character.
Minimum:
This is the minimum value that this tag may be tuned to using the hand
terminal. This value is only required if View Mode is set to Tunable.
Maximum:
This is the maximum value that this tag may be tuned to using the hand
Page 62

SBL Users Guide

terminal. This value is only required if View Mode is set to Tunable.
Data Type:
Select the data type to match that of the value to be displayed on the hand
terminal.
View Mode:
Select Tunable to allow the constant to which this tag is attached to be
tuned using the hand terminal.
Note: Block outputs cannot be connected to tunable tags.
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Adding a Revision Block
Select Revision Block from the Add menu to open the Revision Block
Information dialog box. A revision block can contain up to five revision
descriptions and a sheet can contain any number of revision blocks.

Rev.:
Displays a list of up to five revisions.
Description:
Displays the revision description for each revision in the list
Add
Click this button or press
block.

to add a new revision to the revision

Click this button or press
revision block

to edit an existing revision in the

Edit

Adding and Editing Revisions
The following dialog box will appear when adding revisions to a revision
block. The same dialog box will appear when editing a revision and the title
bar of the dialog box will change to Edit Revision and the revision code and
description of the revision being edited will be displayed.
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Rev.:
Enter a revision code up to 3 characters in length.
Description:
Enter a description of the revision up to a maximum of 20 characters in
length. If all uppercase characters are used SBL may not be able to display
all 20 characters in the space provided.
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Adding a Fault Table
Select Fault Table from the Add menu, or Add Fault Table from the sheet
or macro popup menu to open the Fault Table dialog box. Fault tables may
exist on more than one sheet in a project but if the same fault is defined in
more than one fault table the compiler will generate a warning and the last
fault table processed will be the one which defines the fault message.

Fault:
Fault tables are used to define up to 15 fault messages in an SBL
program. These messages are displayed on the hand terminal when the
appropriate fault code is applied to the fault code input of the config block.
Message:
Position the cursor in the edit box of the message to be edited by clicking
on the box with the mouse cursor or by using the
key or
keys. Type the text to be displayed on the hand terminal for this
fault.
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Adding a Password Table
Select Password Table from the Add menu to open the Handheld
Terminal Passwords dialog box. Password tables can exist on more than
one sheet in a project but if the same password is defined more than once
the compiler will generate a warning and the last password table processed
will be the one which defines the password.

Operator:
Enter the handheld terminal password for Operator access.
Privileged User:
Enter the handheld terminal password for Privileged User access.
System Administrator:
Enter the handheld terminal password for System Administrator access.
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Adding Parameters to Annunciator Files
Select Parameters from the Add menu, or click on the add parameters
button
on the speed bar, to open the Add Parameter dialog box and
add parameters to the current annunciator window. The program must have
been successfully compiled before it's parameters can be added to an
annunciator window.

Program Name:
Displays the name of the program last downloaded to the selected node. If
no program has been downloaded to this node, or if you wish to associate
parameters from a different program with this node, click the Browse
button to select another program.
Browse:
Click this button to browse for the program whose parameters you want to
add to the current annunciator window. These parameters will be
associated with the selected node even if this program has not been
downloaded to that node. See Browse for File for more information.
Node:
Displays a list of nodes already used in the annunciator window as well as
any other currently configured nodes. See Communication Options for
more information on configuring nodes.
Sheet:
Displays a list of all available sheet names for the selected block program.
Select a sheet from this list to display a list of all available parameters on
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that sheet.
Parameter:
Displays a list of all parameters for the selected sheet. These parameters
include all constants and block outputs found on that sheet. Labels that are
attached to block outputs are included in place of the block output name.
All block outputs are included regardless of whether or not they are used in
the program. Select the parameters to be added to the current annunciator
window, multiple parameters can be selected, then click the Add button or
press the

key.
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Adding Macro Inputs and outputs
Select Input from the Add menu to open the Input dialog box or select
Output from the Add menu to open the Output dialog box. Both dialog
boxes are identical with the exception of the title.

Name:
Enter a descriptive name for this input or output up to 15 characters in
length. When macros are added to a sheet or another macro they are
displayed as blocks with input and output names that are defined using the
Input and Output objects. The order in which inputs and outputs appear
when the macro is drawn as a block is determined by their position on the
macro sheet. Inputs are always drawn on the left side of the block and
outputs on the right with the upper-left most object being first and the lowerright most object being last. Precedence is given to left most objects.
Data Type
Select the data type of this input or output to match the data type of the
input it is connected to. This is used by the compiler for type checking
when the program is compiled.
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Edit Object Name
This dialog box appears when editing a block's or macro's name or
whenever a block, macro, constant, tag or a group containing any of these
objects is copied. The title bar of the dialog box will identify the type of object
and in the case of blocks will also identify the type of block to be renamed.
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Project Window
Select Project from the View menu, or click on the view project button
on the speed bar, to open or activate the project window. The project window
lists all files currently included in the project. The execution order of sheet
files is determined by their order in the project window. To change the order
click and hold the left mouse button on dot next to the files icon and drag it to
the new position. Macros cannot be dragged independently of the sheet they
are included in. File types other than sheet and macro files are ignored by
the compiler so they will not affect the execution order even if they are mixed
in with the sheet files. Double clicking on a file name or using the cursor keys
to select the file and pressing
key will open that file. Files can also be
deleted from the project by selecting the file to be deleted and pressing the
key.
If a sheet or macro file's icon has a + symbol in it then that sheet or macro
includes at least one other macro. Clicking on the icon or selecting the file
with the cursor keys and pressing the
bar with open the branch to
show any included files. SBL supports up to 16 levels of nested macros. The
project window is automatically updated whenever a macro is added to, or
deleted from a sheet or macro.
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Compiler Report
Select Report from the View menu to display or activate the compiler report
window. The compiler report is generated as the compiler progresses
through the project list compiling each sheet and macro. Any warnings or
errors generated by the compiler are displayed with the name of the sheet or
macro that contains the warning or error as well as the coordinates of the
object where the problem occurred. If no errors occurred during the compile
a table size summary is also included in the compiler report. See the CA408
Multiprocessor card description in SAFphire Hardware for table size
limitations for the version of the CA408 card being used.
Double clicking on a warning or error message or using the cursor keys to
select the message and pressing the
key, will display the sheet on
which the error occurred and position the cursor at the coordinates where the
problem was detected. Selecting an warning or error message and pressing
the
key will display a detailed explanation of that warning or error
message.
See Compiler Error Messages for a detailed description of the possible
warning or error messages generated by the compiler.
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Symbol Table
Select Symbols from the View menu to display the Browse Symbol Table
dialog box.
If the Browse button in the Add Label dialog box is used to access this
dialog box only those symbols whose names begin with the text entered in
the label name field of the Add Label dialog box will be displayed. If text
was entered in the Sheet Name field of the Add Label dialog box then only
symbols on the source sheet whose names begin with this text will be
displayed. If no text was entered in either field of the Add Label dialog box
all symbols used in the program will be displayed. Also if the Browse
Symbol Table dialog box was accessed from the Add Label dialog box,
selecting a symbol from the list and clicking the OK button will cause the Add
Label dialog box to be filled in with the correct information for the selected
symbol. This helps prevent spelling errors when adding labels to sheet or
macros.
Note: If the active window is a macro then only the symbols available for
that macro will be displayed.

Search Name:
Enter the first few characters of the name of the symbol you're searching
for to help locate it quickly.
Source Type:
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Displays the source type of the symbol. A source type of Constant means
that the symbol is a constant and all labels of the same name connect to
this constant. A source type of label means that the symbol is a label.
Symbol Name:
Displays a list of constant and label names.
Source Sheet:
Displays the name of the sheet on which the constant or source label can
be found. The source label refers to the first label by that name placed on
any sheet in the project.
Usage...
Select a symbol from the list and click this button to display the Symbol
Usage dialog box.
Print
Click this button to print the symbol table. All symbols used in the program
will be listed as well as the number of matching symbols on each sheet.
See A dd Label for more information on labels.
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Symbol Usage
Click the Usage button in the Browse Symbol Table dialog box to display
this dialog box. The usage count of the selected symbol will be displayed for
each sheet or macro that the symbol is used on.

Symbol Name:
Displays the name of the constant or label.
Source Type:
Displays the source type of the symbol. A source type of Constant means
that the symbol is a constant and all labels of the same name connect to
this constant. A source type of label means that the symbol is a label.
Source Sheet:
Displays the name of the sheet on which the source symbol is located.
Usage:
Displays a list of all sheets on which labels of the same name are found.
The number of matching labels on each sheet is also displayed.
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Total Usage:
Displays the total number of occurrences of this symbol in the program.
Find
Select a sheet from the usage list and click this button to find the first
occurrence of this symbol on that sheet. The sheet will be opened if it is not
already and the cursor will be located at the first matching symbol found.
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Print Queue
Select Print Queue from the View menu to display the current status of the
print spooler.

Currently Spooling:
Displays the name of the file currently being printed.
## Files in Queue:
Displays a list of the files waiting to be printed.
Remove
Select a file in the queue list and click this button to remove that file from
the print queue.
Abort
Click this button to remove all files from the print queue.
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Annunciating
Select Annunciate from the Tools menu to toggle the annunciator on and
off. A check mark will be displayed beside this menu item when the
annunciator is on. Activating the annunciator will install the currently selected
communication module if it is not already installed. See Communication
Options for more information on communication modules. Once the
annunciator is activated all open annunciator windows will be annunciated as
well as magnified views of constants and blocks. The status bar will display
the annunciating message and the number of parameters being annunciated.
The status bar will also display an update indicator that will indicate how
quickly the parameters are being updated. Each time the indicator advances
one position all parameters have been updated. Only the parameters that are
completely visible in each annunciator window are annunciated.

Tuning Parameters
Select the constant to be tuned in the annunciator window or press the space
bar to display a magnified view of a constant on a sheet. Then press the
key to display the Tune Constant dialog box.

Constant:
Displays the name of the constant being tuned.
Value:
Displays the actual value of the constant. To tune the constant type the new
value in the Value edit box. The constant can also be tuned by clicking on
the up or down arrow buttons at the end of the Value edit box or by
pressing the
cursor keys. Using the arrow buttons or the cursor keys
will default to incrementing or decrementing the value by one, press and
hold the
key to increment or decrement by ten, or press and hold
the
key to increment or decrement by one hundred. Using the arrow
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buttons or the cursor keys to tune the value will immediately send each new
value to the SAFphire. New values that are typed are not sent until the
Send button is clicked or the
key is pressed.
Send
Click this button or press the
displayed in the value edit box.

key to send the value currently

Editing Parameters
Numeric parameters can also include precision and units information. When
parameters are added to an annunciator window they inherit the precision
and units of any tag connected to the parameter. The precision and units of
any numeric parameter can be edited be selecting the parameter and
pressing the
key or by double clicking the left mouse button on the
parameter to be edited.

Parameter:
Displays the name of the numeric parameter being edited.
Precision:
Enter the precision in terms of the number of digits to be displayed to the
right of the d ecimal point.
Units:
Enter a description of the value to be displayed. The units can be up to
seven characters in length and contain any displayable character.
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Configuring Nodes
Nodes are configured by assigning a name to the node. All references to this
node will be by the name assigned to the node when the node is configured.
This dialog box also appears when editing a selected node, the title bar will
change to Edit Node and the selected node number and name will be
displayed. Both the node number and name can be edited.

Node:
Enter the node number of the node being configured. This number must
match the switch settings of the CA408 card. See the CA408
Multiprocessor card description in SAFphire Hardware for more
information.
Node Name:
Enter a unique name up to 15 characters in length to be used when
referring to this node.
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Annunciator Node List
Click the right mouse button when the cursor is over a text annunciator
window, or press the
key when the active window is a text annunciator
window, to open the Annunciator Node List dialog box.
All annunciator files contain a node list that includes the node number and
name of each node referenced by parameters in the annunciator file. The
annunciator node list also contains the path and name of the parameter file
used when the parameters were added to the annunciator file. Although in
most cases it should not be necessary for the user to edit the annunciator
node list this dialog box is provided to eliminate the need to recreate a text
annunciator file if any of the information contained in the node list becomes
invalid. This can happen when a project is copied and/or renamed or a
SAFphire's node number is changed. Select the node to edit and click the
Edit button or press the
keys to open the Edit Annunciator Node
dialog box. This allows the user to annunciate a node other than the one used
when the parameters were added to the annunciator file. If a project
containing an annunciator file is copied to another directory, or is renamed,
the parameter file in the annunciator node list will still refer to the old
parameter file. If this occurs it will be necessary to edit the parameter file
path for the affected nodes. SBL will attempt to locate the parameter file
automatically and will prompt the user to locate it if it is not found.
Note: The annunciator node list is independent of the communication
node list.

Node:
Displays the node number of the node to be annunciated for any
parameters referencing this node.
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Node Name:
Displays the name assigned to the node.
Parameter File:
Displays the path and name of the parameter file containing the
parameters for this node.
Edit
Select a SAFphire node and then click this button to edit that nodes
annunciator configuration. See Edit Annunciator Node for more
information.
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Edit Annunciator Node
The Edit Annunciator Node dialog box allows the user to change the node
that will be annunciated for parameters referencing this node name. The
node name can also be edited but this only affects the name that is displayed
in the annunciator window. This dialog box can also be used for manually
locating the correct parameter file for the node if the project has been
copied.

Node:
Enter the node number of the node being configured. This number must
match the switch settings of the CA408 card. See the CA408
Multiprocessor card description in SAFphire Hardware for more
information.
Node Name:
Enter a unique name up to 15 characters in length to be displayed in the
annunciator window for parameters that reference this node.
Parameter File:
Displays the current parameter file containing the parameters that
reference this node. This text will scroll when the cursor reaches the edges
of the edit box. The path and or name of the file can be edited by typing the
new path and or file name or by clicking the Browse button or pressing
to browse for the file.
Browse
Click this button to browse for the parameter file to be used for parameters
referencing this node. See Browse for File for more information.
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Browse For File
The Browse For File dialog box is displayed when the annunciator cannot
locate a parameter file and the user chooses to browse for the file. This
dialog box is also displayed when user clicks the Browse button in the Edit
Annunciator Node dialog box to search for the node's parameter file and
when the user clicks the Browse button in the Add Parameter dialog box to
search for a project. Select the directory and the appropriate file and click the
OK button or press
to select the file.
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Downloading a Program
Select Download from the Tools menu to download the current program. If
the program has been modified since it was last compiled SBL will prompt
the user to compile before downloading. If the download inhibit input of the
system config block is enabled the message Download Denied by
SAFphire will be displayed. Check the Force Download check box to
override the download inhibit. A status window will be displayed showing the
progress as each table of the program is downloaded. Check the
Download Project check box to download a compressed project archive
containing all files that have been added to the project. This project archive is
saved in non-volatile memory in the SAFphire and can later be uploaded
from the SAFphire using Upload Project.

Node:
Select the node to download the current program to. Only nodes that have
been previously configured will be listed. See Communication Options for
information on configuring nodes.
Force Download
Check the Force Download check box to override the download inhibit
input to the system config block.
Download Project
Check the Download Project check box to download a compressed project
archive containing all files added to the project. This check box is only
visible when the Data Compression Library DLL is present in the SBL
directory.
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Selecting a Node
Some tools that are used to communicate with a SAFphire require the user
to select a SAFphire node to communicate with. SAFphire nodes must be
configured and assigned a node name before they can be communicated
with using these tools. See Communication Options for more information.

Node:
Select the SAFphire node to communicate with from the list of previously
configured nodes.
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Downloading Firmware
Select Download Firmware from the Tools menu to download a new
version of embedded firmware to a SAFphire. There are currently three types
of embedded firmware that can be downloaded to a SAFphire, 320
Firmware, 386 Firmware and Boot Block Firmware. SAFphire processor
cards are shipped with the current version of firmware already loaded but in
some cases it may be necessary to change the firmware after installation.
Although these changes are usually made by a SAF Engineer, this feature is
provided to allow the user to carry out such changes under the guidance of a
SAF Engineer. Care needs to be taken to ensure that the SBL block library
being used is compatible with the 320 firmware running in the SAFphire. The
user can determine the version of firmware currently running on a SAFphire
by displaying the Node Status of the SAFphire.
Note:
Only newer versions of the CA408 processor card support this feature. See
the CA408 Multiprocessor card description in SAFphire Hardware for more
information on this feature.

File Name:
Enter the name of the file to download or select it from the list of available
files. If no extension is specified the type of file to open will default to 320
firmware.
List Files of Type:
Use this drop down list box to display the list of available file types.
Selecting a file type from this list will display a list of all existing files of the
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selected type in the selected directory.
Below is a list of available file types that can be opened from this dialog
box:
320 Firmware
386 Firmware
Boot Block Firmware

(sbl*.bin)
(code*.bin)
(boot*.bin)

Directories:
The selected directory will default to the directory that contains the
SBL.EXE file.
Drives:
Use this drop down list box to select a different drive from which to
download the firmware file.
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Uploading the Data Table
Select Upload from the Tools menu to upload the data table for the current
program. This allows the user to update all constants on all sheets of the
program after constants have been tuned either from the annunciator or the
handheld terminal. SBL uploads from the node that the current program was
last downloaded to. If no download record for this program is found the user
will be prompted to select the node to upload from. SBL then checks that the
same program is running on that node and has not been modified since it
was downloaded. If the program has been modified since it was downloaded
the user will be prompted to continue, depending on the changes that were
made SBL may not be able to update the constants. The block table is then
uploaded and compared to the block table of the current program. If no
differences are found a Remote Save command is then sent to the
SAFphire and the data table is uploaded. If the size of the data table has not
changed SBL will then proceed to update all constants on all sheets with the
values found in the data table. The status bar will display the progress as
each of these steps are executed.
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Displaying Node Status
Select Node Status from the Tools menu to display the status of the
selected SAFphire node. SBL uploads the status table from the selected
node and displays it in the node status dialog box.

Program Name:
Displays the name of the program currently running on this node.
Downloaded By:
Displays the user name of the user that was logged in to SBL when this
program was downloaded.
Compiled:
Displays the date and time that the program currently running on this node
was compiled.
Downloaded:
Displays the date and time that the program currently running on this node
was downloaded.
8044 Version:
Displays the version number of the communication processor firmware.
For SAFphires with a newer version of the CA408 processor card this
refers to the version of 386 firmware.
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320 Version:
Displays the version number of the main processor firmware.
Drive Status:
Displays the current state of the Status Code input of the
System Config block. The five valid status codes are:
Running
Jog
Stopped
Error
Faulted
Note: If there is no System Config block in the program
currently running on this node the default status code is
Running.
No Tune since download
Indicates if any parameters have been tuned from the hand terminal since
the program was downloaded to this node.
No Tune since last save
Indicates if any parameters have been tuned from the hand terminal since
the the last Remote Parameter Save command.
No upload required
An upload is required if any parameters have been tuned and a Remote
Save command executed since the program was downloaded.
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Scope
Select Scope from the Tools menu to display the Scope Configuration
dialog box.

Parameters:
Displays a list of up to 16 parameters to be annunciated by the scope.
Time Base:
Specify the time per horizontal division to be used when displaying the
waveforms. The time base can be any value from 10 msecs. to 65535
mins. The scope window is divided into 10 horizontal divisions.
Disable Scrolling
On some computers scrolling the scope window when the waveform
reaches the right edge of the window may be to slow and cause some data
to be lost. Disable scrolling and when the waveform reaches the right edge
of the window the scope window will be cleared and the waveforms will
start again at the left edge of the window.
Interpolate Numeric Data
Selecting this option will cause the waveforms to be drawn with diagonal
lines between sampled values. This can result in smoother waveforms by
Page 93

SBL Users Guide

lines between sampled values. This can result in smoother waveforms by
eliminating the steps normally displayed between sampled values.
Start
Click this button to open the scope window and start displaying waveforms.
Close
Click this button to cancel all changes and close the scope configuration
dialog box.
New
Clicking this button will erase the current scope configuration so that a new
configuration may be entered.
Load
This button allows the user to load a previously saved scope configuration
file. Scope configuration files can be loaded into both scope and chart
recorder configuration dialog boxes.
Save
Click this button to save the current scope configuration to a file.
Add
Click this button to open the Add Parameters dialog box to select
parameters to be annunciated.
Delete
Select a parameter from the parameter list and click this button, or press
the
key, to delete the parameter. SBL will prompt the user
confirming this action before any parameters are deleted.
Options
Select a parameter from the parameter list and click this button to open the
Parameter Options dialog box. This allows the user to edit the parameters
min. and max. values as well as the Name and units to be displayed for this
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parameter.
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Chart Recorder
Select Chart Recorder from the Tools menu to display the Chart
Recorder Configuration dialog box. If a trigger expression is entered the
chart recorder can be triggered manually by pressing the
key while the
message " Waiting for trigger ..." is displayed in the status bar.

Parameters:
Displays a list of up to 16 parameters to be recorded by the chart recorder.
Trigger Expression:
Trigger expressions can be used to define an event that will trigger the
chart recorder to start recording data. By entering Pretrigger and
posttrigger times the user can select to have data recorded both before
and after the trigger event. Trigger expressions are entered as a Boolean
equation using logical and relational operators as well as parentheses.
Parameters are referenced using the single character identifier displayed
in parameter list. The following is a list of operators available in order of
precedence.
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Parentheses
Logical operators
!
Not
&
And
|
Or
Relational Operators
(All relational operators have the same order
of precedence)
=, == Equal
<>, != Not equal
<
Less than
<=
Less than or equal
>
Greater than
>=
Greater than or equal

PreTrigger Time:
Enter the length of time to record data preceding the trigger event.
PostTrigger Time:
Enter the length of time to record data following the trigger event.
Interpolate Numeric Data
Selecting this option will cause the waveforms to be drawn with diagonal
lines between sampled values. This can result in smoother waveforms by
eliminating the steps normally displayed between sampled values.
Start
Click this button to start recording data.
Close
Click this button to cancel all changes and close the chart recorder
configuration dialog box.
New
Clicking this button will erase the current chart recorder configuration so
that a new configuration may be entered.
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Load
This button allows the user to load a previously saved scope configuration
file. Scope configuration files can be loaded into both scope and chart
recorder configuration dialog boxes.
Save
Click this button to save the current chart recorder configuration to a file.
Add
Click this button to open the Add Parameters dialog box to select
parameters to be recorded.
Delete
Select a parameter from the parameter list and click this button, or press
the
key, to delete the parameter. SBL will prompt the user
confirming this action before any parameters are deleted.
Options
Select a parameter from the parameter list and click this button to open the
Parameter Options dialog box. This allows the user to edit the parameters
min. and max. values as well as the Name and units to be displayed for this
parameter.
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Scope Configuration Files
Scope configuration files can be loaded into both the Scope Configuration
and Chart Recorder Configuration dialog boxes. These files are completely
interchangeable between scope and chart recorder configurations. Only
relative information is loaded into the appropriate dialog box and any
missing information is initialized to default values.

Loading Scope Configuration Files

File Name:
Enter the name of the scope configuration file to open or select it from the
list of available files.
List Files of Type:
Scope configuration files are the only file type that can be selected using
this dialog box.
Directories:
If a project is open the project directory will be selected otherwise the
selected directory will be the directory that contains the SBL.EXE file.
Drives:
Use this drop down list box to select a different drive from which to open
the scope configuration file.
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Saving Scope Configuration Files

File Name:
Enter the name of the file to save the current scope or chart recorder
configuration to. If a file name is selected from the list of existing files the
user will be prompted to confirm that the new file will overwrite the existing
file.
List Files of Type:
Scope configuration files are the only file type that can be selected using
this dialog box.
Directories:
If a project is open the project directory will be selected otherwise the
selected directory will be the directory that contains the SBL.EXE file.
Drives:
Use this drop down list box to select a different drive from which to open
the scope configuration file.

Page 100

SBL Users Guide

Editing Scope and Chart Recorder Scales
Click the right mouse button with the cursor over a scope or chart recorder
window to open the Scope Channel Scales dialog box.

Parameters:
Displays a list of available parameters that have been added to the scope
or chart recorder configuration.
Edit
Select a parameter from the parameter list and click this button to edit the
Parameter Options for this parameter.
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Parameter Options
Click the Options button in the Scope or Chart Recorder configuration
dialog boxes to open the Parameter Options dialog box.

Parameter:
Displays the selected parameter's full name which includes the sheet
name, block name and output name. If the parameter is a constant or label
the block name is replaced with CONSTANT or LABEL respectively and
the output name is the constant or label name.
Data Type:
Displays the parameter's data type as Numeric or Boolean
Display Name:
The display name is the name that is displayed in the scope or chart
recorder window for this parameter. The default for the display name is the
parameter's output name but the user can change this to any name up to
15 characters in length.
Units:
Enter the units that will be displayed for this parameter. If the parameter
has a Tag attached to it this will default to the Tag's units. The units can be
up to 7 characters in length.
Max:
Enter the maximum value that will be displayed for this parameter. If the
parameter has a Tag attached to it this value will default to the Tag's max.
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value otherwise it will default to 32767. This value can be any value
between -32768 and 32767 and is used for calculating the scale used for
this parameter.
Min:
Enter the minimum value that will be displayed for this parameter. If the
parameter has a Tag attached to it this value will default to the Tag's min.
value otherwise it will default to -32768. This value can be any value
between -32768 and 32767 and is used for calculating the scale used for
this parameter.
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Editor Options
Select Editor from the Options menu to display the Editor Options dialog
box.

Block Library:
Select the SBL block library that contains the blocks to be used when
creating SBL block programs.
Grid Mode
Select the drawing mode to be used when displaying the grid in sheet and
macro windows. Depending on the processor and video card being used,
selecting Dots for the grid mode can cause sheet and macro windows to
be redrawn slowly. Selecting Lines as the grid mode is a faster method of
displaying the grid but depending on the colors selected it can be difficult
to see the objects. Select None to prevent SBL from displaying a grid
when drawing sheet and macro windows.
Display Mode
Select between monochrome and color display modes. In
monochrome mode SBL uses a default set of colors consisting mainly of
white on black to improve readability on LCD laptops. When color mode
is selected SBL will default to the same monochrome colors but the user
can then edit the colors by clicking on the Edit Colors button.
Edit Colors
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Click this button to open the Edit Colors dialog box. This will allow the user
to customize the colors used by SBL when drawing sheet and macro
windows. All printing is done in monochrome mode regardless of the
display mode settings.
Display Data Table Offsets
Selecting this option displays the data table offsets assigned to all blocks
and constants by the compiler. The data table offsets are displayed in
hexadecimal format. The offsets for blocks are
displayed below the name of each input and output. A constant's offset is
displayed below the constants name to the right of the value. This option
was added as an aid for development and debugging of SBL and will be
of little use to most users.
Display Execution Order
Selecting this option displays the execution order assigned to all blocks
during compile.
The execution order is displayed at the bottom of each block. Macros that
contain more than one block will display a range of execution orders to
indicate that more than one block is executed by the macro. This feature is
useful as a means of verifying that blocks are being executed in the order
intended by the user.
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Editor Colors
Click the Edit Colors button in the Editor Options dialog box to display the
Editor Colors dialog box.

Object Type
Lists all of the objects and other elements for which the colors can be
edited.
Outline
Click on the Outline box beside the Object Type to edit that objects color.
This is the color used when drawing the graphical portion of an object, that
is all parts other than text. Some objects have no graphical portion and
therefore this color selection is not available.
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Text
Click on the Text box beside the Object Type to edit that objects text
color. This is the color used when displaying the text portion of an object.
Some objects have no text portion and therefore this color selection is not
available.
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Communication Options
Select Communications from the Options menu to display the
Communication Options dialog box. Select and install the communication
protocol to be used when communicating with SAFphire nodes. Configure
the node identification for all SAFphire nodes to communicate with by
assigning the node a name.

Protocol
Select the communication module to be used when communicating with
SAFphire nodes. Each module supports a specific communication
protocol. The module you choose will depend on the hardware installed on
both the computer and the SAFphire nodes. Additional hardware and/or
modules may be available in the future. Contact SAF Drives and
Automation for more information.
Install
Click this button to configure and install the selected communication
module.
About
Click this button to display a description and version information for the
selected module.
Node:
Displays a list of currently configured SAFphire nodes. All SAFphire nodes
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must be assigned a name. This name is used to identify the SAFphire
node during communications.
Node Name:
Displays a list of names currently assigned to SAFphire nodes.
New
Click this button to open the Add Node dialog box and configure a new
SAFphire node. See Configuring Nodes for more information on
configuring SAFphire nodes.
Edit
Click this button to open the Edit Node dialog box and edit a previously
configured SAFphire node. See Configuring Nodes for more information
on configuring SAFphire nodes.
Delete
Select a SAFphire node or name from the lists and click this button or
press
to delete the selected node.
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Keyboard Usage
The function of the following keys depends on the type of window currently
active. See the Mouse section for information on using the mouse.

All Windows
Press this key for context sensitive help.

Sheet and Macro Windows
Use the cursor keys to move or copy objects as well as draw
connections. The cursor keys can also be used to scroll the sheet by
toggling on scroll lock. The cursor must be inside the active sheet or
macro window before the cursor keys become active. When the
cursor is moved to the edge of sheet window using the cursor keys
the sheet will scroll each time the cursor key is pressed.
Position the cursor over an object and press the
key to
"grab" the object. A grabbed object is displayed with an outline.
Once grabbed an object can be moved, copied or deleted. Use the
mouse or the cursor keys to move or copy the object and press the
key again to release the object.
Position the cursor over an object and press the
bar to
toggle between normal and magnified view. Magnified views of
blocks and constants are annunciated when the annunciator is
enabled.
To copy an object grab and position the object as if moving it but
press and hold the
key and press the
key to release
the copied object. All objects except title blocks can be copied
including groups of objects. SBL will prompt the user for a new
name for all copied blocks, macros, constants and tags.
Position the cursor over an object and press the
that objects properties.

key to edit

To delete an object position the cursor over the object, press the
key to grab the object, then press the
key to delete
the object.
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Press the
key after grabbing an object to cancel the
operation without making any changes. The
key can also be
used to close dialog boxes without saving changes as if the cancel
button had been clicked.
Press the
key when annunciating a magnified view of a
constant to tune the constant's value. See Tuning Parameters for
more information.
Press the
key while holding the
key to change the
cursor to the block help cursor. Position the cursor over a block and
click the left mouse button, or press the
key, to display a
detailed description of that block.

Project Window
Use the
list.

and

cursor keys to select a file from the project file

Press the

key to open the selected file.

Press the

key to add files to the project file list.

Press the
key to remove the selected file from the project
file list. SBL will prompt to confirm this action before any files are
deleted.

Report Window
Use the
cursor keys to select a warning or error message
from the compiler report.
Press the
key to display the cause of the selected warning
or error message. The sheet containing the warning or error will be
displayed and the cursor will be positioned at the point where the
warning or error was detected.
Press the

key to display a detailed description of the selected
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warning or error message.

Annunciator Windows
Use the

cursor keys to select a parameter.

Press the
and units.

key to edit the selected parameter's precision

Press the

key to add parameters to the annunciator window.

Press the
key to remove the selected parameter from the
annunciator window. SBL will be prompt the user to confirm this
action before any parameters are deleted..
Press the
key while annunciating to tune the selected
constant's value. See Tuning Parameters for more information.
Press the
key to view and edit the annunciator file's node list.
See Annunciator Node List for more information.

Scope and Chart Recorder Windows

Pressing the escape key will stop both the scope and the chart
recorder.
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Mouse Usage
The function of the mouse buttons depends on the type of window currently
active. See the Keyboard section for addition commands and shortcuts
using the keyboard.

Sheet and Macro Windows
Left Mouse Button
Press and hold the left mouse button while the cursor is over an object to
"grab" that object. Use the mouse to drag the object to a new position.
Release the mouse button to "drop" the object in the new position. To copy
the object to this position hold the
key when releasing the left mouse
button. To delete the object press the
key while holding the left mouse
button. Double click the left mouse button while the cursor is over an object to
edit that objects properties.
Right Mouse Button
Click the right mouse button while the cursor is over the sheet or macro
window, but not over any object, to pop up a floating menu which contains
some of the more frequently used menu commands for this window. Press
and hold the right mouse button while the cursor is over an object to display a
magnified view of the object. The magnified view of blocks and constants will
be annunciated if the annunciator is activated.

Project Window
Left Mouse Button
Click the left mouse button while the cursor is over a file name to hi light that
file. Double click the left mouse button while the cursor is over a file name to
open the file. Press and hold the left mouse button while the cursor is over a
files bitmap to drag that file to a new position in the file list.
Right Mouse Button
Click the right mouse button while the cursor is over the project window to
pop up a floating menu which contains some of the more frequently used
menu commands for this window.
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Report Window
Left Mouse Button
Click the left mouse button while the cursor is over a message to hi light that
message. Double click the left mouse button while the cursor is over a
warning or error message to display the sheet on which the error occurred.
The cursor will be positioned at the coordinates given in the message.
Right Mouse Button
Click the right mouse button while the cursor is over the report window to pop
up a floating menu which contains some of the more frequently used menu
commands for this window.

Annunciator Windows
Left Mouse Button
Click the left mouse button while the cursor is over a parameter to hi light that
parameter. Double click the left mouse button while the cursor is over a
numeric parameter to edit that parameters precision and units.
Right Mouse Button
Click the right mouse button while the cursor is over an annunciator window
to pop up a floating menu which contains some of the more frequently used
menu commands for this window.

Scope and Chart Recorder Windows
Left Mouse Button
Has no function in this window.
Right Mouse Button
Click the right mouse button while the cursor is over a scope or chart
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recorder window to pop up a floating menu which contains some of the more
frequently used menu commands for this window.
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Technical Support
SAF Drives and Automation
88 Ardelt Avenue
Kitchener, Ontario
Canada
N2C 2C9
Toll Free 1-800 3 ASK SAF (Canada and U.S)
Tel: (519) 743 5491 (24 hour Service)
Fax: (519)743-3610
email: support@safdrives.com
internet: www.safphire.com
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